WP-Forum <= 2.3 SQL Injection & Blind SQL Injection vulnerabilities
SQL injection and blind SQL injection in the WP-Forum plugin for WordPress.
Antecedentes
WP-Forum is a discussion forum plugin for WordPress, compatible with WordPress 2 or later and PHP 5.0 or later.
Description
WP-Forum does not sanitize user input and is vulnerable to SQL injection and blind SQL injection. An attacker can retrieve any data from the database, including WordPress users and passwords, and gain access and administrative privileges. In the SQL injection, other queries can be concatenated with the union select statement through the search_max and forum parameters.
Business impact
Unauthenticated users can retrieve or delete data from the database, which could grant access to WordPress accounts, including the administrator account.
Affected systems
WP-Forum up to version 2.3.
Solución
Update to version 2.4.
Calendario de divulgación
References
The information contained within this advisory is supplied 'as-is' with no warranties or guarantees of fitness for use or otherwise. Internet Security Auditors accepts no responsibility for any damage caused by the use or misuse of this information.
Company based in Spain and Colombia, specializing in web application auditing, network security, penetration testing, and compliance implementation and assessment. Our clients include some of the largest finance, telecommunications, insurance, and ICT companies. A vendor-independent provider with in-depth experience since 2001. Our R&D efforts include vulnerability research, collaboration on open security projects, whitepapers, and participation in industry events.
Would you like us to review your product?
Contact usDo you need a security audit?
Tell us about your situation and our team will get in touch with you to provide guidance or schedule a technical call.
Request information
Our offices
Transversal 22 # 98-82, Porta 100 Building, Office 1003
110221 Bogotá (Colombia)
