ModSecurity < 2.5.9 is vulnerable to a remote Denial of Service (DoS)
Remote denial of service in ModSecurity via a crafted multipart/form-data request.
Antecedentes
ModSecurity is the world's most widely used web application firewall, with over 15,000 users. It runs as an Apache server module, is developed by Breach Security, and is available under the GNU GPL license and several commercial licenses.
Description
The ModSecurity multipart processor does not sufficiently sanitize user input. An attacker can send a crafted multipart/form-data POST request that causes a remote denial of service. The flaw is in the multipart_get_arguments function in the msc_multipart.c file.
Business impact
An attacker could cause a remote denial of service of an Apache installation with the ModSecurity 2 module.
Affected systems
ModSecurity between 2.5.5 and 2.5.8; other versions may be affected. Tested with Apache httpd 2.2.11.
Solución
Update to ModSecurity version 2.5.9.
Calendario de divulgación
References
The information contained within this advisory is supplied 'as-is' with no warranties or guarantees of fitness for use or otherwise. Internet Security Auditors accepts no responsibility for any damage caused by the use or misuse of this information.
Company based in Spain and Colombia, specializing in web application auditing, network security, penetration testing, and compliance implementation and assessment. Our clients include some of the largest finance, telecommunications, insurance, and ICT companies. A vendor-independent provider with in-depth experience since 2001. Our R&D efforts include vulnerability research, collaboration on open security projects, whitepapers, and participation in industry events.
Would you like us to review your product?
Contact usDo you need a security audit?
Tell us about your situation and our team will get in touch with you to provide guidance or schedule a technical call.
Request information
Our offices
Transversal 22 # 98-82, Porta 100 Building, Office 1003
110221 Bogotá (Colombia)
